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Getting Started

The Dune Map Editor is the official tool for creating maps for Emperor: Battle for Dune. With a little effort and a pinch of imagination, you can construct varied and exciting maps for use in skirmish and multiplayer games… 

Installing map editor

Unzip the mapeditor.zip to a local drive. Go to the mapeditor directory and look for DuneMapEditor.exe and use this to run the application. We advise that you place a shortcut to DuneMapEditor.exe on your desktop. 

Resource.cfg

Check this file in the mapeditor folder – it should contain the pathways needed to edit maps and build them into your emperor\data\maps directory. You need to double-check that the final line ‘Game_Maps’ points to the location where you have installed the game. It should look something like this…

GAME_MAPS

c:\westwood\emperor\data\maps

If your game installation is different from this, change this line to point to where the game is installed on your machine. 

The mapeditor should automatically create a ‘maps’ folder wherever the game is installed – the playable versions of your maps will be deposited in this folder.
Creating new map files (.dme)

Double-click the DuneMapEditor shortcut and you should see the following interface…
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The blank grid is the map space – a simple 2d representation of the map layout, upon which you can place cliffs, ramps, objects, buildings etc. Each square represents a tile in the game; by default each tile is treated as sand.  

The first time you use the map editor, a Create New Map interface appears, allowing you to determine the proportions of the map (defaults to 96x96) as well as the name of the output map folder (i.e. the name of the map as it will appear in the skirmish setup screen) and the mapedit file save name (.dme).

Creating a new map:

1. Select a world (e.g. Arrakis) from the world ini file drop down menu
2. Click in the Map name box and type in a name
3. Type in Map Height box (multiples of 4, min 64, max 256)
4. Type in Map Width box (multiples of 4, min 64, max 256)
5. Click OK

When you start up the mapeditor tool again, the Create New Map dialog box does not appear automatically – rather the mapeditor opens the previously used file. However, starting a new map is quite simple….

To start a new map file:

1. Click File on the menu bar

2. Select New (and follow the sequence described in Creating a new map.)

Opening existing files

You can open a saved dme file and continue to edit that. 

Note that a .dme file is contains the map information in an editable format – you cannot use the .dme file to play your map in the game. (To make the playable version of your map, you need to ‘build’ it from the .dme file and this will output a map folder in your emperor/data/maps directory. The folder is the ‘playable’ version of your map – see Build Map, page 16)

1. Choose File > Open
2. Select desired .dme file > click OK
Save/Save As

Choose File > Save/Save As
Your work will be saved in .dme format in the maps subdirectory in your mapeditor folder. Note: If the Save option is greyed out, you will have to build the map first and this should ‘re-enable’ Save.

Map space view controls 

To view different portions of the map space, you can zoom in/out, scroll left/right/up/down. 

To Zoom in: 

<PageUp> key

To Zoom out:

<PageDown> key

To Scroll Left/Right/Up/Down:

<Left/Right/Up/Down arrow> keys or use the horizontal or vertical scroll bars

If you have a mouse wheel, this can be also used to zoom in and out.

                                                                                                                                                 Map Building

Once you have the name and dimensions for your map, you’re ready to put down the important building blocks that will make your map. It’s always a good idea to have a picture in your mind of the map layout (players positions, base size etc) before getting your hands dirty – a rough sketch on paper helps no end. 

You should think of a map in terms of layers – each tab on the right hand sidebar represents a layer (Zones, Game Elements, Objects, Buildings, Spice, Tiles, Details, Sand – a short description of each will be given in the next section). As a rule of thumb, work on each ‘layer’ in the following sequence:- 1)Zone 2)Game Elements 3)Objects…as set out in the following sections, to make your map ‘operational’. 

We recommend that you follow the Map Editor Tutorial document and acquaint yourself with the basic steps.

Layers/Tabs 

Click on each tab to access the respective layer.

Zones

The Zones layer allows you put down raised areas of rock (upon which players can build their bases in-game) onto the map space. The rock outlines are made up from Profiles, which are connected by a series of points.

· LODs
LOD (Level of Detail) determines how complex/natural your rock formations will appear. 0 is the lowest setting and 2 is the highest. We recommend that you work in LOD 0 and build in LOD 2.  The lowest LOD reveals overlapping outlines (see Troubleshooting Common Errors and Problems and Issues) – which can prevent you from building a map.

To change LOD:

Click in the LOD box and type 0,1 or 2
or

Click the LOD counter 

· Adding Profiles

To add profiles to the map space: 
1. Click the Add button

2. Double click the desired profile from the Profiles list (e.g. Sandberm6tall)

3. Click on the map space (repeat until you’re satisfied with the rock outline)

4. Click the right mouse button to stop adding more points

NOTE: When creating rock areas, it’s not advisable to mix tall profiles with short profiles (this deforms the plateaus and looks bad). As a rule, you can mix any of the rockclifftall profiles together on Arrakis (or anything that contains ‘tall’ for offworld maps). Alternatively you can judge which profiles go together by looking at the Profile cross-section – short profiles are generally 2 squares high and tall profiles are 3 (see diagram)

[image: image2.jpg]Profiles

verhang2
overhang
sandiseend

(- Profie





· Changing Profiles

You’ll often need to change profiles on points to place ramps on the rock areas or you might want to vary the outlines….

To Change a Profile:

1. Click the Move button

2. Double-Click the Profile from the Profiles list

3. Click on the Profile point you want to change

4. Press the <Space> bar 

(…Repeat points 3 and 4 as necessary)

· Inserting/Removing Profile Points

To insert a profile point on an outline:

Click on a profile point > Press the <insert> key

To remove a profile point on an outline:

Click on a profile point > Press the <delete> key

· Moving Profiles

To Move a Profile Point:

1. Click the Move button

2. Click on a point > hold the left-mouse button down > drag

To Move a Profile Outline:

1. Click the Move button

2. Click on the area inside an outline > hold the left-mouse button down > drag
· Rotate

To Rotate an whole Profile outline:

1. Click the Rotate button

2. Click on the area inside an outline

3. Hold the left-mouse button down > drag the mouse right or left rotate the rock outline clockwise/anti-clockwise

· Scale
      To Scale an Profile outline:

1. Click the Scale button

2. Click on the area inside an outline

3. Hold the left-mouse button down > drag the mouse left to reduce scale or drag right to increase scale

· Ramps and Cliffs
Refer to the Tutorial on this subject

Whereas it’s probably best to experiment with different profiles to get the right look, here are some suggested profiles for joining ramps and cliff on an Arrakis map. When a cliff profile meets a ramp profile, you will need connect them with the appropriate ramp join profile….

Cliffs Rockclifftall1, Rockclifftall2, Rockclifftall3

Ramps Ramptall1, Ramptall2

Left Cliff/Ramp Join RampjointallL
Right Ramp/Cliff Join RampjointallR

For Caladan maps, you’ll notice that there are no rampjoins that you can use from the profile list. It’s recommended that grassramp profiles should be used for entire profile outlines (i.e. shouldn’t be mixed with cliffs.) For profile outlines that use ‘AtmanmadecliffTall’ – place a specially made object ‘Atwallramp.xaf’ against the profile boundary – to act as the ramp (see Placing Objects, page 11.)

· Changing a Profile Outline Surface texture 

Every now and then, you might want to change a surface texture of a profile outline (for example, when you create a dustbowl the surface texture defaults to ‘rock’ – you’ll need to replace this with a dustbowl texture.) Substituting a surface texture is simple….

To change a surface texture:

1. In the zones layer, click on top of the profile outline that you wish to change

2. Press the <T> key

3. A ‘Select A Texture To Use’ window appears – go to mapeditor/data/textures subdirectory and click on the texture you want to use (e.g. dustbowl.tga for dustbowls or sea.tga for Caladan rivers.)

4. Click Open. You’ll notice that the profile outline is now labelled as the newly applied texture.

Game Elements

The Game Elements layer allows you to place basepoints, map entrance points, AI Zones, resource points and script points onto your map.

· Bases

Basepoints determine where a player’s (or computer player’s) MCV or prebuilt base will be located at the start of a game. Base points must be placed on buildable rock. Clearly if you have 8 basepoints on a map, you’ll have an 8 player map.

Ensure that one ‘Default’ base and at least one ‘Primary’ base is placed onto the map space (secondary bases are an optional extra).

To place a base:
1. Select Base from the Game Element drop-down menu

2. Select Default or Primary from the Element Type drop-down menu

3. Click the Add New button 

4. Left click on the map space (where you want the base to appear)

5. Right click the mouse to stop placing new basespoints

· Entrances

Entrance points determine where reinforcements spawn from in the single player game and where forces exit the map (for example if units have been hawk-striked). You need to be sure that entrance points are accessible on sand (i.e. not cut off by inaccessible rock formations or terrain).

To place an entrance point:

1. Select Entrance from the Game Elements drop down menu

2. Click the Add New button

3. Left click on the map space

4. Right click the mouse to stop placing new entrances

· AI Zones (Cliff & Valley)
AI Zones tell the computer which areas of the map it should exploit to use certain tactics. Placing these zones requires a little foresight – for example if you can see sand area which makes a good ‘pinch point’, consider marking this area as a Valley defence zone.

To place an AI Zone:

1. Select AI Zone from the Game Elements drop down menu

2. Select Cliff or Valley from the Element Type drop down menu 

3. Click Add New
4. Click as many times as needed on the map space

5. Right click mouse to deselect AI Zone option

· Resource
Resource tells the AI where it can harvest spice from. Make sure this point coincides with a spice mound or spice patch.

To place a resource point:

1. Select Resource from the Game Elements drop down menu

2. Click Add New
3. Left click on the mapspace.

4. Right click to deselect

Objects (.XAFS)

Objects (.xafs) is the generic term for landmarks, rock formations and non-usable structures that can be used to enhance the aesthetic quality of the map (examples are bridges, rockstacks and ruins). Unlike buildings, they are permanent features and cannot be destroyed by the player in-game.

Note: Some objects are intended for use on rock areas whereas others should be placed on sand. As a rule of thumb, if an object name contains the word ‘rock’ it should be used on rock (e.g. Rockcrevasse.xaf) and those that don’t contain ‘rock’ can be used on sand (e.g. Crevasse.xaf). 

When you’re trying out objects on your map, it’s a good idea to get a preview of what they will look like in the game, so use the View map option for a 3d view (see View Map & Viewer Controls, page 16).

· Placing Objects 

To place an object on the mapspace:

1. Click the Objects tab

2. Select an object from the object list (e.g. crevasse1.xaf)

3. Click on the map 

· Moving Objects

To move an object on the mapspace:

Click on the object placeholder (diamond shape – see diagram) > hold mousebutton > move
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· Duplicating Objects

To duplicate an object on the mapspace:

Click once on the object placeholder (pink=selected, yellow=deselected) > rightclick the mouse once > object superimposes over the original, move it where necessary.

· Deleting Objects

To delete an object:

Click on the object placeholder > hold down the mouse button and press the <delete> key

· Rotating Objects

To rotate an object:

1. Click on the object placeholder

2. Hold down the <Shift> key > Click left mousebutton

3. Move mouse left or right

· Lowering Objects

You may find that you want to sink objects deeper into the ground in order to make them look good…

To lower an object:

1. Click on the object placeholder

2. Hold down the <F> key (an outline around the placeholder denotes that it has been lowered)

3. <optional> Click the <F> again to raise the object to original level

· Showing Game Objects on the mapspace
If you find the map space too cluttered to work on, you can toggle the objects off to get a better view….

To toggle ‘show game objects’ off/on: 

Click Map on the menubar > Select Show Game Objects

Buildings

The buildings list includes buildings available to each tech tree, incidental buildings, crates, trees and so on. Buildings placed in the mapeditor can be destroyed in-game. Furthermore ownership can be assigned to each building (player, enemy, neutral).

· Inserting  

To insert a building on the mapspace:

1. Click the Buildings tab

2. Select Building Side (click the Player, Enemy or Neutral radio button)

3. Click Buildings or Crates in the Buildings explorer window > Select from the building list

4. Drag building onto the mapspace > click to place.

Note: If building outline is red – this means that it cannot be placed (placing it will result in a pop-up warning). A green building outline informs you that you can put down the building on the desired location. 

· Deleting
To delete a building:

Click on the building > press the <delete> key 

· Rotating buildings

The mapeditor allows you to rotate a building so that it faces North, East, South or West…

To rotate a building:

1. Select building from the building list > drag building outline (don’t place it just yet)

2. Press <Space> bar each time to rotate building face clockwise

Spice

On this layer, you can designate spice patches (finite supplies of spice) or single spice mounds (which replenish their spice over a period of time). Both must be placed on sand….

· Spice Zones
To designate a spice zone:

1. Click on the Spice tab

2. Click the Add New Spice Zone button

3. Click the left mouse button as many times as needed to shape the spice zone

4. Click the right mouse button to stop placing spice.

· Spice Mounds
To place a spice mound:

Click the Add New Spice Zone button > Click on a tile on the map space

To delete a spice zone:

Click on the spice zone > press the <delete> key

Tiles

The tile layer data determines how terrain is to be treated in game - i.e if it’s impassable rock, buildable rock, ramp, sand, dustbowl and so on. Whenever you build a map, the computer makes a best guess as to how tiles should be treated. However you’ll need to manually paint in things like ramps, dustbowls and infantry rocks as the computer can’t recognize these tile areas.

· Tile Types

Cliff – impassable rock used to paint cliff faces and rivers (to stop units from wandering onto them)
Dustbowl – paint on dustbowls. Impassable to all units except Dustscouts, Laser Tanks and Ordos APCs
Infantryrock – impassable to vehicles. Confers armour bonuses to infantry.
Mapedge – don’t use
Nonbuildrock – passable to all units, but buildings cannot be placed on these tiles

Ramp – must be manually painted on, allows access between rock and sand

Rock – allows buildings to be placed on it

Sand – Passable to all units, accessible to sandworms

To paint tiles onto the mapspace:

1. Click on the Tiles tab

2. Select Tile type
3. Hold down mouse button and paint as necessary

· Brush Sizes
To adjust brush head size (maximum 10):

Type in number field below the Tile types box or click on the up/down arrows

· Removing Tiles

To undo tile data:

1. Select brush size

2. Hold down the <Shift> key and paint over the tiles (you’ll notice that white tile outlines will be removed, the computer overwrites this tile data when you rebuild the map)

· Painting In Ramps

Painting Ramps requires more care and attention than other tile types because if basepoints do not have ramps that precisely connect the rock to the sand, it’s likely that the map editor will produce the error ‘No ramps defined’.

A painted ramp should look something like the following diagram…
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Make sure that the ramp is amply sized and that each of the green ramp tiles touches the rock tiles at the top and the sand tiles at the bottom.

Sand

The Sand Layer allows you to draw troughs and bumps over sand surfaces – allowing you to break up flat expanses with sand dunes. By default the sand height is set at 16.

      To vary the sand height:

1. Click the Sand tab

2. Right-click on the map space once and left click each point to draw the sand dune.

To remove a sand dune:

Click once on the sand outline > press the <Delete> key

Building and viewing your work

Build Map

Once you have the important layer information down on your map, you can build it straight away. Once built, the editor outputs a new map folder directly into your Emperor\DATA\maps directory. 

      To build a map:
Select Map from the menubar > Select Build Map
You will see a build finished box when the process is finished.

View Map & Viewer Controls

View Map allows you to see your work in 3d (you can pan, rotate and zoom as you would in the game.)  While viewing the map, you can take a 2d (top down) screenshot of it. These screenshots may be used as the basis for a colourwash and map thumbnail later on.

Note: When you see the 3d preview of your map, it will only display the 3d terrain. You won’t be able to preview things like buildings and spice. It doesn’t mean they’re not there – the buildings and spice will appear once you’re playing the map in the game. 

· Viewing the map

To view the map:

      Select Map from the menubar > Select View Map

· Viewer Controls
To pan:

Use Mouse or <up/down/left/right arrow> keys

To rotate:

Hold down <Ctrl> key and press <left/right arrow> keys

or

Hold down Left and Right mouse buttons > move mouse left or right 

To zoom:

Use Mouse Wheel 

or

Hold down the <Ctrl> key and press <up/down arrow> keys

To take a 2d screenshot:

Press <T> key (this will change the 3d view to a top-down view)

To quit the viewer:

Press <ESC>

Sharing your map with other players

Now that your map has been built, you probably want to distribute and share the playable version of map (the newly generated map folder – as opposed to the .dme file) with other players.

The procedure is really straightforward – just make sure that the target player has a maps directory in his Westwood/Emperor/Data folder, and copy your map subdirectory (& all its contents) into the target player’s maps directory. New maps can be zipped up and sent as well – so long as the target player unzips it into his maps subdirectory. 

Note: To successfully play your new map over LAN/internet – make sure exactly the same version of the map is being shared!! Maps must have the same folder name and contain exactly the same data.

Finishing Touches

In this section, we’ll describe several things you can do to improve the look of your map….

Using Shadowmaker

Shadowmaker is an application supplied with the map editor, which allows you to set lighting conditions and cast shadows over your 3d terrain map. It is very straightforward to use….

1. Double-click the Shadowmaker.exe (in your map editor folder). An application window called ‘Parameters for Shadow Generator’ appears.

2. We need to direct the shadowmaker to the map folder that you want to generate shadows in. Click Browse (next to the Map File Name field.)

3. Look in C:\Westwood\Emperor\Data\maps and click on the map folder that needs shadowing.

4. Click OK
5. Click the down arrow next to the Shadow Settings drop-down list

6. Select a setting – lets say ‘dawn.ssf’

7. Click on the Display Map when finished checkbox (we want to see a 3d preview of the shadowed map)

8. Click the Create Shadows button

9. A progress bar appears. When the shadowing is complete, a 3d preview appears on screen showing you the lighting/shadow conditions on your map. Move your mouse around to move the viewpoint.

10. Press <ESC> to quit the viewer. 

The shadowing is complete. Next time you play your map, you will notice the difference straightaway!

One thing to note - the shadowmaker will generate shadows over terrain features but not over editor-placed buildings. The reason for this is simple  –buildings don’t need them because they’ll have real-time shadows cast in the game. 

Map Colourwash

A map made in the Emperor map editor will be textured.  These textures are comparatively simple and can be seen to repeat.  Colour washing a map allows the tiling of the basic textures to be disguised and interesting details drawn onto the map. However, the colour wash is an optional part of any map made in the Emperor editor and is not required for the map to be played in the game.

Each colour wash texture is a 2048x2048 32 bit tga.  In the game, this image is projected onto the top of the map geometry and combines with the textures on the map itself.  The image has a colour channel and an alpha channel.  The alpha channel is greyscale and determines how transparent the colour channel will appear on the map geometry.  White on the alpha channel means that the colour wash will over ride the textures on the geometry completely.  Black means that the colour channel will not appear at all and it will appear that there is no colour wash on the map.  Grey means that the colour will appear on the map but that the underlying texture will show through.  

If the colour channel is pure pink and has a totally white alpha channel, then the map will appear pure pink.

If the colour channel is pure pink and has a totally black alpha channel, then the map will appear uncolourwashed.

If the colour channel is pure pink and the players name is written in white on a black background in the alpha channel, then the name will appear in solid pink on an otherwise un colourwashed map.

To be visible on a map, the colourwash must be named as test.tga and placed within the map folder created by the map editor for the new map.  While only a 256 tile by 256 tile map would use all of the colour wash texture, the tga must always be 2048x2048 to ensure it fits correctly onto the map.

How to Make a Colour Wash.

Quick ‘n dirty method 

This is the fastest way to push out a colourwash. Essentially you’re going to take a screen capture and use this as a guide to modify the existing default colourwash (the test.tga supplied in your map subdirectory.)

1. Take a screen captured image of your map while viewing it in mapeditor view (press T)

2. Open the screen capture in Photoshop (the capture will be called something like *mapdump_000.tga)

3. We need to resize it so that the capture has the right proportions. Select Image > Image Size
4. Resize it to width 2048, height 2048 pixels (constrain proportions off)

5. The screen capture image is now much larger. We are only interested in the visible portion of the map (not the unused blank sandy-colored portion). Using the Rectangular Marquee tool, select the map image. Copy it.

6. Now open the default test.tga (located in your map subdirectory.) You should see a brown textured surface. Paste your selection onto this.

7. Use the Move tool and drag the pasted image so that it fits snugly in upper left corner of the brown texture image.

8. Select the Magic Wand tool, hold down Shift and click on all visible rock patches (until they are completed selected). ~ Or ~ Use the Lasso tool to select them. 

9. Click Window on the menu bar > Select Show Channels
10. At the bottom of the channels list, click Alpha1
11. You should see the selection outline on the alpha channel. Select Image from the menu bar > Adjust > Brightness/Contrast
12. We want the rock to look more dramatic. Increase the Brightness scale (+18) and the Contrast scale (+42). Click OK
13. Finally we need to remove the capture image that was pasted in step 6. Click Window on the menu bar > Show layers. Now delete Layer1.

14. Save your work (must remain as test.tga). You’re done.

Professional method

The following procedure is the one that the team used for Emperor.  There are other ways but this seems the easiest.  The procedure is for a simple Arrakis map.

1 - Load the map into the map editor.  Build the map and press T.  This will generate a top down screen captured image in the main map editor folder.  Close the map editor.

2 - Open Photoshop.  Load in the screen captured image of the map.  Using Image - image size with the constrain proportions OFF, make the image 2048 x 2048.  Save it as a psd for now.

3 - Now we make our selection guides.  Make a new layer.  Using the Pencil tool, paint over all the terrain that looks like rock with 100% solid black.  This is our rock selection guide

4 - Select the black area that you have just painted.  Create and new layer and on that new layer invert the selection (Select - Inverse).  The area selected should be mainly the sand and other non rock areas.  Paint this area solid black.  This is our sand selection guide.  There should be no visible colours now except for black as the two layers should meet exactly.

5 -  Save.  Its too boring to have to do that bit again.

6 -  Make the sand selection guide invisible (using the eye symbol on the left of the layer display).  Pick the magic wand tool and ensure that the anti aliased check box is OFF in the magic wand options box.  Select the black area and then Select - similar.  All the black areas that correspond to the rock should be selected now.  

7 - Create a new layer.  This will be the rock layer.  Paint this with a solid colour - the basic colour that you wish the rock to be on your map.  Then use other colours and filters to create variety.  We use a variety of techniques:-

· Use the Burn Tool

· Use the paintbrush set to colour dodge

· Noise filters set to monochromatic on a low setting (Filter - Noise - Add noise)

· Accented edges (Filter - brushstrokes - accented edges) with edge width set to 1 or 2, edge brightness high or low and smoothness between 1 and 5. 

· Using the magic wand tool with no anti aliasing after the burn and noise filters have been applied to select irregular 
shapes.  Hold the shift key down and click around the map to pick random areas.  These sections can then be brightened or have their contrast increased (Image - adjust - brightness/contrast)

8 - Save again

9 - Repeat stage 6 and 7 but this time hide the rock selection guide, make the sand selection guide layer visible, select the black and select similar, create a new layer and then paint the sand using the techniques outlined in 7.  This will be your sand layer.

10 - On the sand layer and the rock layer, paint a small innocuous section of colour in each of the four corners.  This will help with the selection of these layers when we come to pasting them onto the alpha channel.

11 - Select the rock layer, and press ctrl-A to select all.  Copy that layer (shortcut Ctrl C).

12 - Select channels on the Layer/Channels/Actions window.  Click on the arrow on the top right and select new channel.  Click OK.  A new channel called alpha 1 should appear.

13 - select alpha 1 channel and paste in the rock layer we copied from the other layer (ctrl -V).  It will be grey scaled, which is fine.

14 - Go back to layers and select the sand layer.  Ctrl A to select all and copy this.  Return to the channel and paste the sand level into alpha 1 channel.  There should be no gaps between them within the border of the map area.

15 - Save

16 - Using brightness and contrast, and the burn and dodge tools, lighten and darken the parts of the alpha 1 channel.  Remember that any pure white sections will cause the full colourwash to be opaquely projected onto the map while black sections will not show up at all.  To form more complex patterns on rocks or sand, try using the accented edges filter on selected areas of the channel, increasing the noise on areas of the alpha channel, or even using the rubber stamp tool to rearrange the alpha so it does not correspond to the colour layers.  This is where most of the experimentation takes place.

17 - The colour wash is now virtually complete.  However, there are a couple of extra stages that can work well.  If these are not of interest, skip to 20.

18 - Paths, tracks and sand swirls can be drawn quite carefully onto a map.  Returning to the layers section, hide all the layers except the original background of the map screen shot.  Create a new layer and then, taking note of the way the cliff lines and other geography is flowing, begin to paint on these details.  These mostly work best in lighter colours than the basic sand colour.  Once the layer is complete, paint colours into each corner then select all.  Copy and paste this selection onto the alpha 1 channel.  Without unselecting, increase the brightness a little to make sure the details are seen.

19 - As the colour wash is projected straight down over the map, certain areas can look quite poor with a strong colour wash on them.  To stop this happening, create a new layer and paint with a soft edged brush in black over all cliff edges, ramp tops, large structures and even infantry rock.  Paint small drops of colour in each corner for selection purposes, then select all and copy and paste onto the alpha 1 channel.  This will mask those areas out from the colour wash.

20 - Save the PSD.  Ensure that you keep the psd with all the layers intact as it allows easy editing and alteration of the colourwash.  To get a colourwash right requires constant viewing of it in the game followed by tweaks to the image.

21 - Ensure that any layers that have guides or masked areas on them are hidden.  Then flatten the image, saying yes to "discard hidden layers".  Then SAVE AS test.tga in the map folder itself (if you’re asked to overwrite the existing test.tga – the default one supplied by mapeditor - click Yes.)  The image should be 32 bit.

22 - Go into the game and view your map with your colour wash.

The Shadows on a map can also be painted in photoshop.  Using "Open As" in the file section and selecting open as .RAW file, followed by "OK" on the resulting query window, the texture.dat file may be viewed and edited.  If the image is inversed (Image - adjust - invert) it can be understood a little easier.  Mostly photoshop is used to remove artifacts and smooth out edges, but sometimes extra details like pits and dunes may be painted on.  Do not forget to reinvert the image before saving.

Compressing the Colourwash

Colourwashes (test.tgas) tend to be quite large (at around 16 megabytes each!) and this is not ideal. Therefore we strongly recommend that you use our compressor tool to make the colourwash smaller and easier to transmit.

The tool is called Washcompressor.exe and it is located in the map editor folder.

To compress a test.tga colourwash:

1. Double-click Washcompressor.exe

2. A Select File dialog box appears. Go to C:\Westwood\Emperor\Data\Maps and go into the map subdirectory that contains your colourwash.

3. Click on the file Test.tga (this is the colourwash). 

4. Click the Open button

5. Test.cpt now appears in the File name box. Click the Save button

6. The process takes a few moments. A ‘done’ confirmation box appears, click OK.

7. Now you can remove the original test.tga (it is no longer needed) from the map subdirectory (in emperor\data\maps\..). If the files test.cpF and test.cpt (the compressed colourwash) are present, delete test.tga.

Good – now your colourwash is compressed and you’re done.

Map Preview Thumbnail

All the maps in the Skirmish and Custom game screens have small preview thumbnails – we suggest that you do the same for your map. The process is simple….

· Preview Thumbnail

To make a thumbnail:

1. Switch to LOD 2 > Select Map > View Map
2. When you see the 3d view of your map, press the <T> key

3. The screenshot has been taken. Press <ESC>

4. This outputs a *MapDump0.tga to your Mapeditor folder. Open your screenshot in Photoshop or another image editor.

5. Open the .tga called !05%thumb (supplied with the map editor, in the ‘thumbnail’ folder) in Photoshop.

6. Crop and resize the *MapDump0.tga so that it is small enough to fit onto the !05%thumb image > Copy and paste the cropped image into !05%thumb
7. Save the new image into your Emperor/data/maps/$yourmapname$ folder. Rename it so that it reads !05%thumb.tga.  

Troubleshooting Common Errors and Problems 

The following section describes some of the common problems that can occur during the map design process and offers solutions to them….

Intersecting profile outlines

Symptom:

You get the Error message ‘Found a self intersecting zone/boundary – cannot build…’ after selecting Build Map 

Solution:

Go to the Zones layer and drop from LOD 2 to 0. You should be able to see the intersecting boundary/outline – the outline points will have pink triangles around them (see diagram.) Move the outline points until the triangles disappear.
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No Base Positions

Symptom:

You get the Error message ‘No default base position defined’ and/or ‘No base positions defined’ after selecting Build Map 

Solution:

Go to the Game Elements layer, place 1 default base and 1+ primary bases on the map.

No Entrance Points 

Symptom:

You get the Error message ‘No entrance point defined, there must be at least one’ after selecting Build Map

Solution:

Go to the Game Elements layer, place 1+ entrance points on the map edge.

No Ramps

Symptom: 

You get the Error message ‘No Ramps Defined’ after selecting Build Map

Solution: 

Go to the Tiles layer, and manually paint in the ramps tiles in the right places

BasePositions too close to mapedge

Symptom:

You get the Error message ‘Base Position too close to the edge of map at (x,y)’ after selecting Build Map

Solution: 

In this situation, the mapeditor has identified the baseposition as being invalid, because a prebuilt base using these coordinates would crash the game. Go to the Game Elements layer, and look for the base point (your current cursor coordinates are displayed in the bottom left of the mapeditor interface). Ensure that you move the basepoint at least 5 tiles away from the mapedge and rebuild.

Hindered Routefinding:

Symptom: 

In the game, units have difficulty getting around the map (portions of the map appear to be inaccessible.) It’s a routefinding nightmare!

Solution: 

Make sure all rock areas have accessible ramps - check the tiles layer. Ensure bridges and pinch points have a width of at least 4 tiles (move profile outlines and objects accordingly) so that the largest vehicle units can pass through them. Also check that certain terrain tile types do not ‘partition’ off sections of the map (e.g. if dustbowls cut off access to a base point – only certain Ordos vehicles can traverse them)

Deformed Rock Surfaces

Symptom: 

A supposedly buildable rock surface looks deformed (it’s not flat and has a dip in it) and players are unable to build anything on it….

Solution: 

Go to the Zones layer and check the surrounding profiles on the deformed rock. You’ll probably find that you’ve inadvertently mixed tall profiles with short profiles – ensure that they all points share the same profile height.  

Incorrect Tile Data

Symptom: 

When playing your map in the game, your infantry units are unable to mount infantry rocks and Ordos hover units are unable to traverse dustbowls.
Solution: 

During the build process, the computer wasn’t able to interpret the dustbowls or infantryrock, and consequently placed ‘cliff’ tile data on them. Therefore you’ll need to go to the Tile layer and manually paint dustbowl/infantyrock tiles onto your map.

Tears and Rips

Symptom:

In the game you can see a triangular black ‘rip’ on a sand surface and/or infantry units mysteriously ‘drop’ out of sight (apparently below the rock surface).

Solution:

Its likely that an object .XAF (such as a sand level infantryrock) has been placed so that it intersects/clips a boundary or point of a profile outline. To solve this problem simply move the object away from the boundary.

‘An error has occurred’ message pops-up

Symptom: 

You get the ‘An error has occurred’ pop-up while building a map.
Solution:
This message is exceptionally rare and points to something on your map which is causing a crash (a likely cause is bad object placement.) Mapeditor saves your work as a temporary .dme in the folder where mapeditor is installed and the error message will tell you the map file name. Open this file and try to adjust the positioning of the objects and build the map again.

Hints and Tips

Here is a selection of hints and pointers to help you along your merry way….

Map themes

When designing a map, try to encourage players to adopt different playing styles/strategies. A good example of this is the 2-player map ‘Streetfight’ – the ruined building complex that separates the two bases offers ample opportunity for infantry invasions (Fremen in particular excel on this map!) 

These are some potential themes for maps: Resource fighting (shared or limited spice), Vulnerable/open bases, Infantry cover/optimised, Restrictive base-sizes, Reward-based areas (crates, buildings).

Performance

What can you do to get the best performance out of your map? 

The answer to that question is fairly straightforward. Try to avoid cluttering your map with to many objects – a mass of objects will increase the poly count and will have a performance hit. Also avoid using too many complex objects like trees (opt for simpler objects if possible). 

Try to make the map routefinding as straightforward as possible – units have an easier time negotiating open spaces and they hate narrow, closed pathways. The more routefinding calculations a computer has to make on a map, the slower the performance will be. Keep it simple. 

Finally it may be worth bearing in mind that smaller maps will offer you marginally better performance than large maps. Needless to say, a 256x256 map will contain more polys than a 64x64 (also you’ll be tempted to populate a larger map with more objects). 

Balance

Ideally multiplayer maps should contain basepoints that are perfectly balanced for all players. If one player finds that his base position is cut off from the spice and is even more exposed to attack than the other players’ bases – he/she is doomed from the onset. 

Here are some balance pointers:

· Try to make the basepoints more or less equidistant from each other. Avoid allowing one player to be caught between two enemies i.e. fighting a war on two fronts from the start.

· Rock areas should contain roughly the same amount of building space.

· Ensure that players have equal spice zones. Also don’t give one player a finite spice zone and another a spice bloom (which self-replenishes). 

· Some spice patches should be readily accessible to all players at the start of the game. This puts everyone on an equal footing.

· Try to ensure that there are at least two or three ways of getting into each player base. Generously sized ramps dissuade players from playing ‘turtle’ i.e. sealing themselves inside their own defences and not venturing out.

· Position equal amounts of infantryrock around/in player’s bases.

· Remember that rules are made to be broken.

Keyboard Shortcuts

· To change a rock surface texture, press <T> and select a new texture (in the zones layer).

· To change profile points quickly, click on the point and press the <Space> bar

· The <B> key is an alternative to Map > Build Map
· When you want to rotate an object, hold down the <Shift> key and move the mouse

· Hotkeys for objects: <M> to move, <R> to rotate, <A> to add and <S> to scale.

TECH SUPPORT DISCLAIMER

---------------------------

The map editor is a beta product, and may still contain some bugs, errors, and other

difficulties.  Westwood Studios does not provide customer support for the editor, but

we encourage everyone to visit the Map Editor messageboard forums at http:/www.duneemperor.com.

We will be posting some tips & tricks there, and you can share your findings with others.
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